|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- Internet Storage Name Service
The Internet Storage Name Service (iSNS) provides consolidated discovery services for Internet SCSI (iSCSI) and Internet Fibre Channel Protocol (iFCP) devices in an IP network. iSNS uses a client/server mechanism: servers store configuration information for clients, and provide that information upon a client's request. IETF RFC 4171 describes the protocols between the server and client.
This man page provides a summary of the Solaris iSNS server implementation. The current implementation does not support iFCP devices.
Solaris iSNS server is implemented as the daemon isns, which binds to the well –known port 3205 to service client requests. The daemon is started by the service management facility (smf(5)), using the fault management resource identifier (FMRI):
Use svcadm(1M) to enable isns. Enabling the service means that it starts and runs automatically whenever the operating system is booted. The state of service can be displayed with the svcs(1) command.
The service properties listed below can be managed using svccfg(1M). The default value is assigned per RFC 4171 and implementation choice.
Configuration data store location. The default location is /etc/isns/isnsdata.xml.
Entity Status Inquiry retry threshold counter. The default count is 3.
Boolean that determines whether Management State Change Notification is enabled. The default is yes.
Control node names.
After changing a property value, you must use svcadm(1M) refresh to enable isns to recognize the new value. If you change the data_store_location property, you must enter a svcadm restart command for the change to take effect.
RFC 4171 defines the default discovery domain, the default domain set, and the “Default DD/DDS” setting with the intent of managing clients that have not been assigned to any user-defined discovery domain. The server adopts the following behaviors with respect to the default discovery domain and domain set:
An unassigned client is added to the default discovery domain. A newly registered client or a client that was removed from its last discovery domain membership is considered to be an unassigned client.
When a client gets assigned to a user-defined discovery domain, the server will remove the client from the default discovery domain.
The default discovery domain set is allowed to be administratively activated or deactivated in order to let the administrator control discovery among clients in the default discovery domain.
It is not allowed to administratively add a client to the default discovery domain, nor to administratively add a user-defined discovery domain to the default discovery domain set.
The default state of the Default discovery domain set is inactive.
Required to create a discovery domain or domain set, to enable/disable a discovery domain set and to change grouping of iSNS clients in a discovery domain or grouping of discovery domains in a discovery domain set.
Required to manage the isns server through the smf(5).
Required to change the SMF service properties associated with isns.
There are no options supported by the isns daemon.
Example 1 Starting an isns Server
The following command starts the isns server.
# svcadm enable svc:/network/isns_server
Example 2 Stopping an isns Server
The following command stops the isns server.
# svcadm disable svc:/network/isns_server
Example 3 Changing an isns Property
The following sequence of commands changes the value of the ESI_retry_threshold_count property.
# svccfg -s svc:/network/isns_server setprop \ config/ESI_retry_threshold_count = 6 # svcadm refresh svc:/network/isns_server
iSNS daemon binary.
See attributes(5) for descriptions of the following attributes:
It is strongly recommended that you restart the server (svcadm restart) after a service property is changed. This allows the server to apply a uniform setting for existing and new clients.
A control node, as described in RFC 4171, is not required to administer the server. Control node operations can be achieved through the isnsadm(1M) command interface on the local host. For example, isnsadm enables you to create a discovery domain and a discovery domain set and to add a member to it, in order to create discovery domain and discovery domain set associations.