|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- BSD print protocol adaptor
in.lpd implements the network listening service for the BSD print protocol specified in RFC 1179. The BSD print protocol provides a remote interface for systems to interact with a local spooling system. The protocol defines five standard requests from the client to the server: starting queue processing, transferring print jobs, retrieving terse status, retrieving verbose status, and canceling print jobs.
The in.lpd service is managed by the service management facility, smf(5), under the service identifier:
Administrative actions on this service, such as enabling, disabling, or requesting restart, can be performed using svcadm(1M). Responsibility for initiating and restarting this service is delegated to inetd(1M). Use inetadm(1M) to make configuration changes and to view configuration information for this service. The service's status can be queried using the svcs(1) command.
in.lpd uses the config/log_from_remote property to allow or disallow remote access. The default value of this property, localhost, disallows remote access.
inetd waits for connections on TCP port 515. Upon receipt of a connect request, in.lpd is started to service the connection. Once the request has been filled, in.lpd closes the connection and exits.
Example 1 Allowing Remote Access
The following command allows remote access to in.lpd.
# inetadm -m svc:/application/print/rfc1179:default bind_addr=""
The following exit values are returned:
An error occurred.
System printer configuration database.
NIS version of /etc/printers.conf.
Spooler translation modules.
See attributes(5) for descriptions of the following attributes: