|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- network lock daemon
/usr/lib/nfs/lockd [-g graceperiod] [-l listen_min_backlog] [-t timeout] [nthreads]
It forwards fcntl(2) locking requests for NFS mounted file systems to the lock manager on the NFS server.
It generates local file locking operations in response to requests forwarded from lock managers running on NFS client machines.
State information kept by the lock manager about these locking requests can be lost if the lockd is killed or the operating system is rebooted. Some of this information can be recovered as follows. When the server lock manager restarts, it waits for a grace period for all client-site lock managers to submit reclaim requests. Client-site lock managers, on the other hand, are notified by the status monitor daemon, statd(1M), of the restart and promptly resubmit previously granted lock requests. If the lock daemon fails to secure a previously granted lock at the server site, then it sends SIGLOST to a process.
Administrators can make changes to the startup parameters for lockd by logging in as root and using the sharectl(1M) command.
The lockd service is managed by the service management facility, smf(5), under the service identifier:
The sharectl(1M) command is used to manipulate the startup SMF parameters for lockd. Currently supported parameters are as follows:
Set connection queue length for lockd over a connection-oriented transport. The default and minimum value is 32. Equivalent to -l option.
Maximum number of concurrent lockd requests. The default is 20. Equivalent to the nthreads operand.
Retransmit timeout, in seconds, before lockd retries. The default is 5. Equivalent to -t option.
Grace period, in seconds, that all clients (both NLM and NFSv4) have to reclaim locks after a server reboot. This parameter also controls the NFSv4 lease interval. The default is 90. Equivalent to -g option.
See EXAMPLES, below.
The following options are supported:
Deprecated in favor of grace_period. Specify the number of seconds that all clients (both NLM and NFSv4) have to reclaim locks after the server reboots. It also controls the NFSv4 lease interval. This option is equivalent to the grace_period property described above.
Specify the listener backlog (listen_min_backlog). listen_min_backlog is the number connect requests that are queued and waiting to be processed before new connect requests start to get dropped. Equivalent of the lockd_listen_backlog property described above.
Specify the number of seconds to wait before retransmitting a lock request to the remote server. The default value is 5 seconds. Equivalent of the lockd_retransmit_timeout property described above.
Specify the maximum number of concurrent threads that the server can handle. This concurrency is achieved by up to nthreads threads created as needed in the kernel. nthreads should be based on the load expected on this server. If nthreads is not specified, the maximum number of concurrent threads will default to 20. Equivalent of the lockd_servers property described above.
Example 1 Setting a lockd Property
The following command sets lockd_listen_backlog to a new value:
# sharectl set -p lockd_listen_backlog=40 nfs
The lockd_listen_backlog and other lockd properties are described under NOTES, below.
Example 2 Getting a lockd Property Value
The following command retrieves the value of the lockd_listen_backlog property.
% sharectl get -p lockd_listen_backlog nfs lockd_listen_backlog=40
See attributes(5) for descriptions of the following attributes:
The lockd daemon might not exist in a future release of Solaris.