|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- trace a chain of NTP hosts back to their master time source
/usr/sbin/ntptrace [-vdn] [-r retries] [-t timeout] [server]
ntptrace determines where a given Network Time Protocol (NTP) server gets its time from, and follows the chain of NTP servers back to their master time source. If given no arguments, it starts with localhost.
The following options are supported:
Turns on some debugging output.
Turns off the printing of host names; instead, host IP addresses are given. This may be necessary if a nameserver is down.
Sets the number of retransmission attempts for each host.
Sets the retransmission timeout (in seconds); default = 2.
Prints verbose information about the NTP servers.
Example 1 Sample Output From the ntptrace Command
The following example shows the output from the ntptrace command:
% ntptrace localhost: stratum 4, offset 0.0019529, synch distance 0.144135 server2.bozo.com: stratum 2, offset 0.0124263, synch distance 0.115784 usndh.edu: stratum 1, offset 0.0019298, synch distance 0.011993, refid 'WWVB'
On each line, the fields are (left to right):
The server's host name
The server's stratum
The time offset between that server and the local host (as measured by ntptrace; this is why it is not always zero for localhost)
The host's synchronization distance
The reference clock ID (only for stratum-1 servers)
All times are given in seconds. Synchronization distance is a measure of the goodness of the clock's time.
See attributes(5) for descriptions of the following attributes:
This program makes no attempt to improve accuracy by doing multiple samples.