|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- share, unshare multiple resources
shareall [-F FSType [,FSType]...] [-| file]
unshareall [-F FSType [,FSType]...]
When used with no arguments, shareall shares all resources from file, which contains a list of share command lines. If the operand is a hyphen (-), then the share command lines are obtained from the standard input. Otherwise, if neither a file nor a hyphen is specified, then the file /etc/dfs/dfstab is used as the default.
Resources may be shared by specific file system types by specifying the file systems in a comma-separated list as an argument to -F.
unshareall unshares all currently shared resources. Without a -F flag, it unshares resources for all distributed file system types.
Specify file system type. Defaults to the first entry in /etc/dfs/fstypes.
See attributes(5) for descriptions of the following attributes: