|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- query routing daemons for their routing tables
rtquery [-np1] [-w timeout] [-r addr] [-a secret] host...
rtquery [-t operation] host...
The rtquery command is used to query a RIP network routing daemon, in.routed(1M) or GateD, for its routing table by sending a request or poll command. The routing information in any routing response packets returned is displayed numerically and symbolically.
By default, rtquery uses the request command. When the -p option is specified, rtquery uses the poll command, an undocumented extension to the RIP protocol supported by GateD. When querying GateD, the poll command is preferred over the request command because the response is not subject to Split Horizon and/or Poisoned Reverse, and because some versions of GateD do not answer the request command. in.routed does not answer the poll command, but recognizes requests coming from rtquery and so answers completely.
The rtquery command is also used to turn tracing on or off in in.routed.
The following options are supported:
Causes the query to be sent with the indicated cleartext or MD5 password.
Displays only the numeric network and host addresses instead of both numeric and symbolic names.
Uses the poll command to request full routing information from GateD. This is an undocumented extension RIP protocol supported only by GateD.
Asks about the route to destination addr.
Changes tracing, where operation is one of the actions listed below. Requests from processes not running with UID 0 or on distant networks are generally ignored by the daemon except for a message in the system log. GateD is likely to ignore these debugging requests.
Turns tracing on, directing tracing into the specified file. That file must have been specified when the daemon was started or have the name, /var/log/in.routed.trace.
Increases the debugging level.
Turns off tracing.
Dumps the daemon's routing table to the current trace file.
Changes the delay for an answer from each host. By default, each host is given 15 seconds to respond.
Queries using RIP version 1 instead of RIP version 2.
The following exit values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes:
Routing Information Protocol, RIPv1, RFC 1058
Routing Information Protocol, RIPv2, RFC 2453, STD 0056