|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- get a listing of disk space usage on a remote machine by means of SNMP
/usr/sfw/bin/snmpdf [common options] [-Cu] agent
The snmpdf command is a networked verison of the df(1M) command. It checks the disk space on the remote machine by examining the HOST-RESOURCES-MIB's hrStorageTable or the UCD-SNMP-MIB's dskTable. By default, the hrStorageTable is preferred, as it typically contains more information than the dskTable. However, the -Cu argument can be passed to snmpdf to force the usage of dskTable.
The agent operand identifies a target SNMP agent, which is instrumented to monitor specified objects. At its simplest, the agent specification consists of a host name or an IPv4 address. In this situation, the command attempts communication with the agent using UDP/IPv4 to port 161 of the target host.
See the snmpcmd(1M) manual page for a full list of the possible formats for agent.
See the snmpd.conf(4) manual page for guidance on setting up dskTable using the disk directive in the snmpd.conf file.
The following options are supported:
See snmpcmd(1M) for a list of possible values for common options, as well as their descriptions.
Forces the command to use dskTable in UCD-SNMP-MIB instead of the default to determine the storage information. Generally, the default use of hrStorageTable in HOST-RESOURCES-MIB is preferred because it usually contains more information than dskTable.
Example 1 Obtaining Disk Usage of a Remote System
The following command returns a display of the disk usage of a remote system.
Description size (kB) Used Available Used% / 7524587 2186910 5337677 29% /proc 0 0 0 0% /etc/mnttab 0 0 0 0% /var/run 1223088 32 1223056 0% /tmp 1289904 66848 1223056 5% /cache 124330 2416 121914 1% /vol 0 0 0 0% Real Memory 524288 447456 76832 85% Swap Space 1420296 195192 1225104 13%
See attributes(5) for descriptions of the following attributes:
A usage syntax error. A usage message is displayed. Also used for timeout errors.
An error occurred while executing the command. An error message is displayed.