|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- automated resource pools partitioning daemon
poold [-l level]
poold provides automated resource partitioning facilities. Normally, poold is active on the system whenever the pools facility is active. poold starts and stops when the pool_set_status(3POOL) function activates or deactivates the pools facility. poold starts when you activate pools and stops when you deactivate pools. If you manually stop poold by using a utility such as kill(1), you can invoke it manually.
poold's configuration details are held in a libpool(3LIB) configuration and you can access all customizable behavior from this configuration.
poold periodically examines the load on the system and decides whether intervention is required to maintain optimal system performance with respect to resource consumption. poold also responds to externally initiated (with respect to poold) changes of either resource configuration or objectives.
If intervention is required, poold attempts to reallocate the available resources to ensure that performance objectives are satisfied. If it is not possible for poold to meet performance objectives with the available resources, then a message is written to the log. poold allocates scarce resources according to the objectives configured by the administrator. The system administrator must determine which resource pools are most deserving of scarce resource and indicate this through the importance of resource pools and objectives.
The following options are supported:
Specify the vebosity level for logging information.
Specify level as ALERT, CRIT, ERR, WARNING, NOTICE, INFO, and DEBUG. If level is not supplied, then the default logging level is INFO.
A condition that should be corrected immediately, such as a corrupted system database.
Critical conditions, such as hard device errors.
Conditions that are not error conditions, but that may require special handling.
Messages that contain information normally of use only when debugging a program.
When invoked manually, with the -l option, all log output is directed to standard error.
Example 1 Modifying the Default Logging Level
The following command modifies the default logging level to ERR:
# /usr/lib/pool/poold -l ERR
See attributes(5) for descriptions of the following attributes:
The invocation is Evolving. The output is Unstable.