|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- communicate with a network entity using SNMP BULK requests
/usr/sfw/bin/snmpbulkwalk [application_options] [common_options] [oid]
The snmpbulkwalk utility is an SNMP application that uses SNMP GETBULK requests to query a network entity efficiently for a tree of information.
You can specify an object identifier (OID) on the command line. This OID identifies the portion of the object identifier space that will be searched using GETBULK requests. All variables in the subtree below the given OID are queried and their values returned. Each variable name is given in the format specified in snmp_variables(4). If no OID argument is present, snmpbulkwalk searches MIB-2.
If a network entity has an error processing the request packet, an error packet is returned and a message is displayed. The message helps to pinpoint the way in which the request was malformed.
If the tree search causes attempts to search beyond the end of the MIB, the message "End of MIB" is displayed.
The following options are supported:
Do not check whether the returned OIDs are increasing. Some agents (agents for Laser-Jet printers are an example) return OIDs out of order, but can complete the walk anyway. Other agents return OIDs that are out of order and can cause snmpbulkwalk to loop indefinitely. By default, snmpbulkwalk tries to detect this behavior and warns you when it hits an agent acting illegally. Use -Cc to turn off this behavior.
Include the given OID in the search range. Normally, snmpbulkwalk uses GETBULK requests starting with the OID you specify and returns all results in the MIB tree beyond that OID. Use this option to include the OID specified on the command line in the printed results if it is a valid OID in the tree itself.
Set the non-repeaters field in the GETBULK PDUs. This specifies the number of supplied variables that should not be iterated over. The default is 0.
Upon completion of the walk, display the number of variables found.
Set the max-repetitions field in the GETBULK PDUs. This specifies the maximum number of iterations over the repeating variables. The default is 10.
In addition to these options, snmpbulkwalk takes the common options described in the snmpcmd(1M) manual page.
Example 1 Retrieving Variables Under system
The following command retrieves all of the variables under system:
# snmpbulkwalk -v2c -Os -c public zeus system
The return from snmpbulkwalk is as follows:
sysDescr.0 = STRING: "SunOS zeus.net.cmu.edu 4.1.3_U1 1 sun4m" sysObjectID.0 = OID: enterprises.hp.nm.hpsystem.10.1.1 sysUpTime.0 = Timeticks: (155274552) 17 days, 23:19:05 sysContact.0 = STRING: "" sysName.0 = STRING: "zeus.net.cmu.edu" sysLocation.0 = STRING: "" sysServices.0 = INTEGER: 72
In contrast to snmpwalk(1M), this information will be gathered in a single transaction with the agent, rather than one transaction per variable found. snmpbulkwalk is thus more efficient in terms of network utilization, which might be especially important when retrieving large tables.
A usage syntax error. A usage message displays. Also used for timeout errors.
An error occurred while executing the command. An error message displays.
See attributes(5) for descriptions of the following attributes:
As the name implies, snmpbulkwalk uses the SNMP GETBULK message, which is not available in SNMP v1.