|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- named configuration file syntax checking tool
named-checkconf [-hjvz] [-t directory] filename
The named-checkconf utility checks the syntax, but not the semantics, of a specified configuration file.
The following options are supported:
Display the usage summary and exit.
When loading a zonefile, read the journal if it exists.
Change the root directory to directory so that include directives in the configuration file are processed as if run by a named configuration whose root directory has been similarly changed.
Print the version of the named-checkconf program and exit.
Perform a test load of the master zones found in named.conf.
The following operands are supported:
The name of the configuration file to be checked. If not specified, it defaults to /etc/named.conf.
No errors were detected.
An error was detected.
See attributes(5) for descriptions of the following attributes:
See the BIND 9 Administrator's Reference Manual. As of the date of publication of this man page, this document is available at https://www.isc.org/software/bind/documentation.