|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- remove entries from allocation databases
/usr/sbin/remove_allocatable [-f] -n name
/usr/sbin/remove_allocatable [-f] [-d] -t dev-type
remove_allocatable removes entries of user allocatable devices from the device allocation mechanism. remove_allocatable also removes entries of some non-allocatable devices, such as printers, whose label range is managed by the mechanism.
The following options are supported:
Removes system-supplied default attributes of the device type that is specified with -t.
Force the removal of an entry. remove_allocatable exits with an error if this option is not specified when an entry with the specified device name no longer exists.
Removes the entry for the device name.
Removes devices of type dev-type.
When successful, remove_allocatable returns an exit status of 0 (true). remove_allocatable returns a nonzero exit status in the event of an error. The exit codes are as follows:
Invocation syntax error
Unknown system error
Device name or dev-type not found. This error occurs only when the -f option is not specified.
Permission denied. User does not have DAC or MAC access to database.
See attributes(5) for descriptions of the following attributes:
The invocation is Uncommitted. The options are Uncommitted. The output is Not-an-Interface.
The functionality described on this manual page is available only if the system is configured with Trusted Extensions.