|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- partition manipulation program
parted [options] [device [command [options...]...]]
parted is a disk partitioning and partition resizing program. It allows you to create, destroy, resize, move, and copy ext2, linux-swap, FAT, FAT32, and reiserfs partitions. It can create, resize, and move Macintosh HFS partitions, as well as detect jfs, ntfs, ufs, and xfs partitions. It is useful for creating space for new operating systems, reorganizing disk usage, and copying data to new hard disks.
This manual page documents parted briefly. Complete parted documentation is distributed with the package in “GNU Info” format.
parted is implemented with a set of top-level options and a set of subcommands, most of which have their own options and operands. These subcommands are described below. parted has an optional operand:
The block device to be used. When none is given, parted uses the first block device it finds.
If you invoke parted without an argument, the program displays a command prompt.
The following options are supported:
Sets alignment for newly created partitions. Valid alignment types are:
Use the minimum alignment allowed by the disk type.
Align partitions to cylinders.
Use minimum alignment as given by the disk topology information. This and the opt value will use layout information provided by the disk to align the logical partition table addresses to actual physical blocks on the disks. The min value is the minimum alignment needed to align the partition properly to physical blocks, which avoids performance degradation.
Use optimum alignment as given by the disk topology information. This aligns to a multiple of the physical block size in a way that guarantees optimal performance.
Displays a help message.
Lists partition layout on all block devices.
Displays machine-parseable output.
Never prompts for user intervention.
Displays the version number.
If you omit a subcommand in a parted command line, the utility issues a command prompt.
Do a simple check on partition.
Copy the source partition's filesystem on source-device (or the current device if no other device was specified) to the dest partition on the current device.
Display general help, or help on a command, if specified.
Make a filesystem fs-type on partition. fs-type can be one of fat16, fat32, ext2, linux-wap, or reiserfs.
Create a new disk label (partition table) of label-type. label-type should be one of bsd, dvh, gpt, loop, mac, msdos, pc98, or sun.
Make a part-type partition with file system fs-type (if specified), beginning at start and ending at end (by default, in megabytes). fs-type can be one of fat16, fat32, ext2, HFS, linux-swap, NTFS, reiserfs, or ufs. part-type should be one of primary, logical, or extended.
Make a part-type partition with file system fs-type, beginning at start and ending at end (by default, in megabytes).
Use of this subcommand is discouraged. Instead use mkpart to create an empty partition, and then use external tools such as mke2fs(8) (part of Linux) to create the filesystem.
Move partition so that it begins at start and ends at end. Note that move never changes the minor number.
Set the name of partition to name. This option works only on Mac, PC98, and GPT disk labels. The name can be placed in quotes, if necessary.
Display the partition table.
Exit from parted.
Rescue a lost partition that was located somewhere between start and end. If a partition is found, parted will ask if you want to create an entry for it in the partition table.
Resize the file system on partition so that it begins at start and ends at end (by default, in megabytes).
Choose device as the current device to edit. device should usually be a Solaris or Linux hard disk device, but it can be a partition, software raid device, or an SVM or LVM logical volume if necessary.
Change the state of the flag on partition to state. Supported flags are: boot, root, swap, hidden, raid, lvm, lba, and palo. state should be either on or off.
Set unit as the unit to use when displaying locations and sizes, and for interpreting those given by the user when not suffixed with an explicit unit. unit can be one of s (sectors), B (bytes), kB, MB, GB, TB, % (percentage of device size), cyl (cylinders), chs (cylinders, heads, sectors), or compact (megabytes for input, and a human-friendly form for output).
Display version information and a copyright message.
See attributes(5) for descriptions of the following attributes:
The parted program is fully documented in the info(1) format GNU partitioning software manual.
ext3 filesystem functionality does not currently work. To manage ext3 type filesystems use tools like resize2fs(8) or mke2fs(8) (both part of Linux). Note that the currently supported ext2 filesystem will be deprecated once ext3 support is finalized. Further note that ext3 support will have limited functionality that is yet to be defined. Use tools like resize2fs(8) and mke2fs(8) to manage these types of filesystems.
To manually resize an ext3 filesystem or a partition, use resize2fs(8), fdisk(8), or similar tools. For LVM situations, you will need to use the LVM commands to resize the LVM elements.
This manual page was written by Timshel Knoll for the Debian GNU/Linux system. It is here adapted for the Solaris operating system.