|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- identify files in a specified region of an NTFS volume
ntfscluster [options] device
The ntfscluster utility has three modes of operation: info, sector, and cluster, described as follows.
The default mode, info is currently not implemented. It will display general information about the NTFS volume when it is working.
The sector mode displays a list of files that have data in the specified range of sectors. This mode is put in effect by the -–sector option.
The cluster mode displays a list of files that have data in the specified range of clusters. When the cluster size is one sector, this is equivalent to the sector mode of operation. This mode is put in effect by the -–cluster option.
Supported options are listed below. Most options have both single-letter and full-name forms. Multiple single-letter options that do not take an argument can be combined. For example, -fv is the equivalent of -f -v. A full-name option can be abbreviated to a unique prefix of its name.
Any files whose data is in this range of clusters will be displayed.
Display information about filename.
Overrides some sensible defaults, such as not working with a mounted volume. Use this option with caution.
Show a list of options with a brief description of each.
Show information about this inode.
This option is not yet implemented.
Suppress some debug, warning, and error messages.
Any files whose data is in this range of sectors will be displayed.
Show the version number, copyright, and license information.
Display more debug, warning, and error messages.
Example 1 Displaying Information About a Volume
The following command displays information about the volume /dev/dsk/c0d0p1.
# ntfscluster /dev/dsk/c0d0p1
Example 2 Displaying List of Files in a Cluster Range
The following command looks for files in the first 500 clusters of /dev/dsk/c0d0p1.
# ntfscluster -c 0-500 /dev/dsk/c0d0p1
See attributes(5) for descriptions of the following attributes:
ntfscluster was written by Richard Russon, with contributions from Anton Altaparmakov.