|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- mount a udfs file system
mount -F udfs [generic_options] [-o specific_options] [-O] special mount_point
mount -F udfs [generic_options] [-o specific_options] [-O] special | mount_point
The mount utility attaches a udfs file system to the file system hierarchy at the mount_point, which is the pathname of a directory. If mount_point has any contents prior to the mount operation, these are hidden until the file system is unmounted.
If mount is invoked with either special or mount_point as the only arguments, mount searches /etc/vfstab to fill in the missing arguments, including the specific_options. See mount(1M).
If special and mount_point are specified without any specific_options, the default is rw.
If the directory on which a file system is to be mounted is a symbolic link, the file system is mounted on the directory to which the symbolic link refers, rather than on top of the symbolic link itself.
See mount(1M) for the list of supported generic_options.
The following options are supported:
Specify udfs file system specific options in a comma-separated list with no intervening spaces. The following specific_options are available:
Mount the file system without making an entry in /etc/mnttab.
Remount the file system as read-write. The option is used in conjunction with the rw option.
A file system mounted read-only can be remounted as read-write. This option fails if the file system is not currently mounted.
Overlay mount. Allow the file system to be mounted over an existing mount point, making the underlying file system inaccessible. If a mount is attempted on a pre-existing mount point without setting this flag, the mount fails, producing the error device busy.
Table of mounted file systems
List of default parameters for each file system
See attributes(5) for descriptions of the following attributes:
The command is run by a non-root user. Run as root.
The device name specified does not exist.
The specified mount point is not a directory.
The device specified does not contain a udf 1.50 file system or the udfs file system module is not available.
The specified device is already in use.
The device specified is not a block device. Use block device to mount.
The device is read-only.
The file system is in an inconsistent state. Run fsck.
Copy-protected files can be stored on DVD-ROM media using Universal Disk Format (UDF). Reading these copy-protected files is not possible as this involves an authentication process. Unless an authentication process between the host and the drive is completed, reading these copy-protected files after mounting and before the authentication process, returns an error.