|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- make local resource unavailable for mounting by remote systems
unshare [-F protocol] [-a | [-t] [pathname | sharename]]
The unshare command unpublishes a file system share, which makes a shared local file system unavailable for file sharing protocol. If the -F protocol option is omitted, then the first file sharing procotol listed in the /etc/dfs/fstypes file used as the default sharing protocol.
Identify the file sharing protocol.
Unpublish all active shares.
Temporarily unpublish a share. By default, all shares are permanently unpublished.
List of file sharing protocols. NFS is the default file-sharing protocol.
Contains a table of local resources published by the share command.
See attributes(5) for descriptions of the following attributes:
If pathname or resourcename is not found in the share information, an error message is sent to standard error.
When an unshare command completes successfully, a client mounting a file system specified in that unshare command no longer has access to that file system.