|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- display or change the label on an NTFS file system
ntfslabel [options] device [new_label]
The ntfslabel utility displays or changes the file system label on the NTFS file system located on device (see Synopsis).
If the optional argument new_label is not present, ntfslabel displays the current file system label.
If the optional argument new_label is present, ntfslabel sets the file system label to be new_label. NTFS file system labels can be at most 128 Unicode characters long; if new_label is longer than 128 Unicode characters, ntfslabel truncates it and displays a warning message.
It is also possible to set the file system label using the -L option of mkntfs(1M) during creation of the file system.
Supported options are listed below. Most options have both single-letter and full-name forms. Multiple single-letter options that do not take an argument can be combined. For example, -fv is the equivalent of -f -v. A full-name option can be abbreviated to a unique prefix of its name.
Overrides some sensible defaults, such as not working with a mounted volume. Use this option with caution.
Show a list of options with a brief description of each.
Do not actually write a new label to disk.
Suppress some debug, warning, and error messages.
Show the version number, copyright, and license information.
Display more debug, warning, and error messages.
See attributes(5) for descriptions of the following attributes:
ntfslabel was written by Matthew J. Fanto, with contributions from Anton Altaparmakov and Richard Russon.