|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- network configuration management daemon
netcfgd is a system daemon to manage network configuration. This daemon is started automatically by svc:/network/netcfg:default and should not be invoked directly. It does not constitute a programming interface.
netcfgd manages access to a network configuration repository, insuring that readers and writers have the appropriate authorizations. Specifically, an application wishing to read network configuration must have the solaris.network.autoconf.read authorization; while an application wishing to write network configuration must have the solaris.network.autoconf.write authorization. These authorizations are registered in auth_attr(4), and are included in the Network Autoconf profile found in prof_attr(4).
See attributes(5) for descriptions of the following attributes:
See also nwam-manager(1M), available in the JDS/GNOME man page collection.