|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 1/13 Information Library|
- Intel ICH series, nVidia nForce series and AMD 8111 audio core support.
The audio810 driver provides support for AC 97 audio controllers embedded in Intel ICH, nVidia nForce, and AMD 8111 chips.
Applications that open /dev/audio may use the AUDIO_GETDEV ioctl(2) to determine which audio device is being used. The audio810 driver returns the string SUNW,audio810 in the name field of the audio_device structure. The version field contains a letter “a” and the config field contains the string onboard1.
Key to the above table: Ver. = Version. Out = Line Out. H. Phone = Head Phone. Spkr = Internal Speaker. In = Line In. Mic. = Microphone. CD = CD=ROM.
The audio810 device provides support for the internal speaker, headphone, line out, line in, and microphone. The play.mod_ports and record.mod_ports fields of the audio_info structure (see audio(7I)) indicate which ports may be manipulated.
This driver supports the mixer mode only. (Compat mode is not supported).
The audio810 device supports 16-bit linear encodings in stereo. With the mixer enabled, a continuous range of sample rates from 5510 to 48000 Hz is supported. With the mixer disabled, only sample rate 48000 Hz is supported. This is limited by hardware capability. The device can be opened for simultaneous play and record whether the mixer is enabled or not.
Because the audio810 device manipulates buffers of audio data, the reported input and output sample counts will vary at any given time from the actual sample count by no more than the size of the buffers the audio810 driver is transferring. In general, programs should not rely on the absolute accuracy of the play.samples and record.samples fields of the audio_info structure.
The driver determines how often play and record interrupts should take place. For playing audio, this determines how often and how much audio is requested from the audio mixer. The impact of interrupts on recording is minimal. However, if a very small read buffer size is set, the record interrupt rate should be increased to prevent the buffer from overflowing. The play and record interrupt rates are tunable in the /kernel/drv/audio810.conf file.
audio810 errors are described in the audio(7I) man page.
Symbolic link to the system's primary audio device. (Not necessarily an audio810 audio device).
Control device for the primary audio device.
Represents the first audio device on the system. (Not necessarily an audio810 audio device).
Audio control for /dev/sound/0.
Audio sample files.
audio810 driver configuration file.
See attributes(5) for a descriptions of the following attributes:
AMD-8111 HyperTransport I/O Hub Data Sheet — Advanced Micro Devices Inc.
ALC655 Specification — Realtek Inc.
In addition to being logged, the following messages may appear on the system console:
The play interrupt rate in audio810.conf is set too low. It has been reset to the rate specified in the message. Update audio810.conf to a higher play interrupt rate.
The play interrupt rate set in audio810.conf is set too high. It has been reset to the rate specified in the message. Update audio810.conf to a lower play interrupt rate.
The record interrupt rate in audio810.conf is set too low. It has been reset to the rate specified in the message. Update audio810.conf to a higher record interrupt rate.
The record interrupt rate in audio810.conf is set too high. It has been reset to the rate specified in the message. Update audio810.conf to a lower record interrupt rate.