|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 1/13 Information Library|
- DTrace system call tracing provider
The systrace driver implements the DTrace syscall dynamic tracing provider. The syscall provider performs dynamic instrumentation to offer probes that fire whenever a thread enters or returns from a kernel system call entry point.
The systrace driver is not a public interface and you access the instrumentation offered by this provider through DTrace. Refer to the Solaris Dynamic Tracing Guide for a description of the public documented interfaces available for the DTrace facility and the probes offered by the syscall provider.
See attributes(5) for a description of the following attributes:
Solaris Dynamic Tracing Guide