|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 1/13 Information Library|
- UltraSPARC T1 server crypto provider device driver
The ncp device driver is a multi-threaded, loadable hardware driver supporting hardware assisted acceleration of RSA and DSA cryptographic operations. This support is built into the UltraSPARC T1 processor.
The ncp driver requires the presence of the Solaris Cryptographic Framework to enable applications and kernel clients to access the provided services.
You configure the ncp driver by defining properties in /platform/sun4v/kernel/drv/ncp.conf which override the default settings. The following property is supported:
Disables the generation of statistics. The nostats property may be used to help prevent traffic analysis, but this may inhibit support personnel.
Solaris network drivers must implement statistics variables. The ncp driver maintains the following statistics:
Number of times the queue for MAU X was found full when attempting to submit jobs.
Number of submit job failures on MAU X.
Number of jobs submitted to MAU X since driver load (boot).
Total number of jobs submitted to the device for RSA public key operations.
Total number of jobs submitted to the device for RSA private key operations.
Total number of jobs submitted to the device for DSA signing.
Total number of jobs submitted to the device for DSA verification.
Additional statistics may be supplied for Sun support personnel, but are not useful to Solaris users and are not doc- umented in this manpage.
See attributes(5) for descriptions of the following attributes:
64-bit ELF kernel driver.
Solaris Cryptographic Framework — Solaris Software Developer Collection
Solaris Security for Developer's Guide — Solaris Software Developer Collection