|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 1/13 Information Library|
- Emulex OneConnect 10 GBit Ethernet Adapter Driver
The oce 10 GBit ethernet adapter driver is a STREAMS based GLD (NIC driver) for 10G Ethernet functions on the Emulex OneConnect cards.
The oce driver initializes the NIC functions on the chip and implements send/receive of frames. The driver provides statistics and error reporting. The driver also supports multicast and promiscuous modes for send/receive, VLANs, lso, and so forth. The driver supports mtu of 1500 or 9000.
The device can be configured using the driver configuration file oce.conf or the tool ifconfig.
The mtu can be changed using the following entry in the file /kernel/drv/oce.conf:
oce_default_mt = 9000;
Valid values for oce_default_mt are 1500 (default) or 9000.
The only valid value for speed/mode is 10 Gbps/full-duplex.
The interfaces created by the oce driver can be configured through ifconfig:
ifconfig oce0 plumb xxx.xxx.xxx.xxx up ifconfig oce0 down unplumb
32-bit ELF kernel module
64-bit ELF kernel module, x86
64-bit ELF kernel module, SPARC
See attributes(5) for descriptions of the following attributes:
STREAMS Programming Guide
IEEE 802.3ae Specificiation, IEEE - 2002