|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 1/13 Information Library|
- Tavor uDAPL service driver
The daplt module is the driver component of the uDAPL service provider for Tavor which implements the provider functions of the uDAPL Specification 1.2 described under libdat(3LIB).
The daplt module is a child of the IB nexus driver, ib(7D), and layers on top of the Solaris kernel IB Transport Layer, ibtl(7D). The daplt driver uses the InfiniBand Transport Framework (IBTF). (See ibtl(7D), ibcm(7D), and ib(7D) to access privileged IB VERBS.)
The daplt driver copies out various HCA H/W object reference handles, including working and completion queues and User Access Region registers, to its own uDAPL service provider library for Tavor. The library can refer back to these object handles and use them to mmap(2) in the mapping of these H/W queues and registers from the Tavor HCA driver, tavor(7D). This process enables time-critical non-privileged IB VERBS such as send/receive work elements, RDMA read/write and memory window bind, to be invoked in the userland library and performed directly by the firmware or hardware. As a result, OS and network stack are bypassed, achieving true zero data copy with the lowest possible latency.
64-bit SPARC ELF kernel driver
32–bit x86 ELF kernel driver
64–bit x86 ELF kernel driver
driver configuration file
special character device.
See attributes(5) for descriptions of the following attributes:
uDAPL Specification 1.2