|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 1/13 Information Library|
- Data Layer Class of Service Marker
The dlcosmk marker is an action module that is executed as a result of classifying or metering packets. It marks the packet with a user priority defined by the IEEE 801.D standard. This feature is only possible on a VLAN device.
The 3-bit user priority is part of the 802.1Q VLAN header tag that is part of the ethernet header (carrying the IP packet).
The dlcosmk module exports the following statistics through kstat:
module: dlcosmk instance: <action id> name: dlcosmk statistics class <action name> crtime snaptime b_band <b_band value> dl_max <dl_max value> usr_pri <configured CoS> npackets <number of packets> epackets <number of packets in error> ipackets <number of packets not processed>
See attributes(5) for descriptions of the following attributes: