|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 1/13 Information Library|
- InfiniHost MT23108/MT25208 InfiniBand (IB) Driver
PCI pci15b3,5a44@pci-slot, pci15b3,5a45@pci-slot
PCI-E pci15b3,6278@pci-e-slot, pci15b3,6279@pci-e-slot
The tavor driver is an IB Architecture-compliant implementation of an HCA, which operates on the Mellanox MT23108 InfiniBand ASSP and the Mellanox MT25208 InfiniBand ASSP. These ASSP's support the link and physical layers of the InfiniBand specification, while the ASSP and the driver support the transport layer.
The tavor driver interfaces with the InfiniBand Transport Framework (IBTF) and provides an implementation of the Channel Interfaces that are defined by that framework. It also enables management applications and agents to access the IB fabric.
32-bit ELF kernel module (x86 platform only).
64-bit ELF kernel module (x86 platform only).
64–bit ELF Kernel Module (SPARC platform only).
Driver configuration file.
See attributes(5) for descriptions of the following attributes:
Writing Device Drivers
In addition to being logged, the following messages may appear on the system console.
There was a failure in the boot process of the tavor ASSP and the only function that can be performed is to re-flash firmware on the ASSP.
The ASSP could not boot into either operational (HCA) mode or into maintenance mode. The device in inoperable.
A port state change event occurred, but the port number in the message does not exist on this HCA. This message also indicates the port number that was in the port state change.
The driver has been removed from the system, and the HCA is no longer available for transfer operations.
A port up asynchronous event has occured. “n” represents the instance of the Tavor device number, and “m” represents the port number on the Tavor device.
A port down aynchronous event has occurred.
A internal firmware command failed to execute.