|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 1/13 Information Library|
- HD audio controller generic codec audio core support
The audiohd driver provides support for the generic codec chips which are compatible with the Intel High-Definition Audio Controller 1.0 specification.
Applications that open /dev/audio may use the AUDIO_GETDEV ioctl(2) to determine which audio device is being used. The audiohd driver returns the string SUNW,audiohd in the name field of the audio_device structure. The version field contains a letter “a” and the config field contains the string onboard1.
Key to the above table: Ver. = Version. Out = Line Out. H. Phone = Head Phone. Spkr = Internal Speaker. In = Line In. Mic. = Microphone. CD = CD=ROM.
The audiohd device provides support for the internal speaker, headphone, line out, line in, microphone and replicated front panel audio parts. The play.mod_ports and record.mod_ports fields of the audio_info structure (see audio(7I)) indicate which ports may be manipulated.
This driver supports the mixer mode only. (Compat mode is not supported).
The audiohd device supports 16-bit linear encodings in stereo. With the mixer enabled, a continuous range of sample rates from 5510 to 48000 Hz is supported. With the mixer disabled, only sample rate 48000 Hz is supported.
Because the audiohd device follows the Intel HD Audio specification, buffers of audio data are supplied by streams and the reported input and output sample counts vary at any given time from the actual sample count by no more than the size of the buffers the audiohd driver is transferring. As a rule, programs should not rely on the absolute accuracy of the play.samples and record.samples fields of the audio_info structure.
The driver determines how often play and record interrupts should take place. For playing audio, this determines how often and how much audio is requested from the audio mixer. The impact of interrupts on recording is minimal. However, if a very small read buffer size is set, the record interrupt rate should be increased to prevent the buffer from overflowing. You can use the /kernel/drv/audiohd.conf file to tune the play and record interrupt rates.
audiohd errors are described in the audio(7I) man page.
Symbolic link to the system's primary audio device. (Not necessarily an audiohd audio device).
Control device for the primary audio device.
Represents the first audio device on the system. (Not necessarily an audiohd audio device).
Audio control for /dev/sound/0.
Audio sample files.
audiohd driver configuration file.
See attributes(5) for a descriptions of the following attributes:
Intel High-Definition Audio Specification 1.0. - Intel Corporation
ALC880 Specification — Realtek Inc.
In addition to being logged, the following messages may appear on the system console:
The play interrupt rate in audiohd.conf is set too low. It has been reset to the rate specified in the message. Updateaudiohd.conf to a higher play interrupt rate.
The play interrupt rate set in audio810.conf is set too high. It has been reset to the rate specified in the message. Updateaudiohd.conf to a lower play interrupt rate.
The record interrupt rate inaudiohd.conf is set too low. It has been reset to the rate specified in the message. Update audio810.conf to a higher record interrupt rate.
The record interrupt rate in audiohd.conf is set too high. It has been reset to the rate specified in the message. Updateaudiohd.conf to a lower record interrupt rate.