|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 1/13 Information Library|
- Realtek Fast Ethernet 8139–based network interface controllers
The rtls Ethernet driver is a multi-threaded, loadable, clonable, STREAMS hardware driver supporting the connectionless Data Link Provider Interface, dlpi(7P), over Realtek 8139 controllers. The rtls driver provides basic support for the Realtek 8139 hardware. Functions include chip initialization, frame transmit and receive, multicast support, and error recovery and reporting.
The cloning, character-special device /dev/rtls is used to access all 8139 devices installed within the system.
The rtls driver is dependent on /kernel/misc/gld, a loadable kernel module that provides the rtls driver with the DLPI and STREAMS functionality required of a LAN driver. See gld(7D) for more details on the primitives supported by the driver.
The values returned by the driver in the DL_INFO_ACK primitive in response to the DL_INFO_REQ from the user are as follows:
Maximum SDU is 1500 (ETHERMTU).
Minimum SDU is 0. The driver pads to the mandatory 60-octet minimum packet size.
The dlsap address length is 8.
MAC type is DL_ETHER.
The sap length value is -2, meaning the physical address component is followed immediately by a 2-byte sap component within the DLSAP address.
Broadcast address value is Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF).
The rtls driver only supports Realtek 8139 on x86 platforms.
The rtls driver does not support the NDD interface and MII statistics. Realtek 8139 works under 100FDX/100HDX and 10FDX/10HDX modes, which you can set using the rtls.conf file.
To configure the rtls driver:
Use prtconf -v | grep pci10ec,8139 to obtain the instance number of the driver. (pci1186,1301 or pci1113,1211 indicates a third-party ethernet device with an 8139 chip that can also be controlled by the rtls driver.)
The rtls.conf configuration file options include:
Default: 5 (Auto-negotiate)
Allowed Values: 4 (100 FDX)
3 (100 HDX)
2 (10 FDX)
1 (10 HDX)
Specify the speed and duplex mode for each instance.
Sets rtls0 to autonegotiate and rtls1 to 100 FDX.
Device special file.
rtls configuration file.
stropts network header file.
Ethernet network header file.
dlpi network header file.
gld network header file.
See attributes(5) for descriptions of the following attributes: