jconvru - code conversion STREAMS module (Japanese EUC/UTF—8)
ioctl(fd, I_PUSH, "jconvru");
jconvru is a STREAMS module that is available to be pushed onto a stream. Usually, this module has to be pushed onto a stream between terminal circuit module such as ldterm (7M) and STREAMS compatible module such as ttcompat(7M) .
jconvru has to be pushed when you operate UTF-8 data. It converts up stream for Japanese EUC into UTF-8 and passes high module. It also converts down stream for UTF-8 into Japanese EUC and passes low module.
jconvru processes the following ioctls:
Start performing code conversion between Japanese EUC and UTF-8 for I/O stream.
Stop performing code conversion between Japanese EUC and UTF-8 for I/O stream.
See attributes(5) for descriptions of the following attributes:
When you use jconvru with jconvu (7M), jconvs (7M), jconv7 (7M), or jconv8 (7M) at a time and `raw' is specified by stty(1), code convert function automatically become off without specification by EUC_OXLON / EUC_OXLOFF .