ses - SCSI enclosure services device driver
The ses device driver is an interface to SCSI enclosure services devices. These devices sense and monitor the physical conditions in an enclosure as well as allow access to the status reporting and configuration features of the enclosure (such as indicator LEDs on the enclosure.)
ioctl(9E) calls can be issued to ses to determine the state of the enclosure and to set parameters on the enclosure services device.
No ses driver properties are defined. Use the ses.conf file to configure the ses driver.
The following is an example of the ses.conf file format:
# # Copyright (c) 1996, by Sun Microsystems, Inc. # All rights reserved. # # #ident "@(#)ses.conf 1.1 97/02/10 SMI" # name="ses" parent="sf" target=15; name="ses" parent="SUNW,pln" port=0 target=15; name="ses" parent="SUNW,pln" port=1 target=15; name="ses" parent="SUNW,pln" port=2 target=15; name="ses" parent="SUNW,pln" port=3 target=15; name="ses" parent="SUNW,pln" port=4 target=15; name="ses" parent="SUNW,pln" port=5 target=15; name="ses" class="scsi" target=15 lun=0;
The SES driver currently supports the SES, SAFTE and SEN enclosure service chipsets. SEN and SAFTE protocols are translated internally in the driver into SES compliant data structures. This enables the SES driver to work seamlessly with different protocols and eliminates the need to enhance user applications.
Returns an unsigned integer that represents the number of SES data structures in the enclosure services chip.
Returns a size array containing ses_object elements communicated through SESIOC_GETNOBJ(). ses_object is defined in sesio.h.
Instructs the device to perform a self-diagnostic test. Currently SES & SEN devices always return success.
Returns an unsigned character that represents status enclosure as defined by Table 25 in Section 7.1.2 of the SES specification NCITS 305-199x.
This ioctl is passed an ses_objarg containing the obj_id you want to set, then fills in the remaining fields according to element status page of the SES specification.
Sets options in the control field. You set control field options by filling out all fields in ses_objarg. Field definitions are presented in Section 7.2.2 of the SES specification.
Driver configuration file
See attributes(5) for descriptions of the following attributes: