jconvu - code conversion STREAMS module (UTF-8/Japanese EUC)
#include <sys/types.h>
#include <sys/stropt.h>
#include <sys/conf.h>
ioctl(fd, I_PUSH, "jconvu");
jconvu is a STREAMS module that is available to be pushed onto a stream. Usually, this module has to be pushed onto a stream between a raw device such as ptem (7M) and terminal line discipline module such as ldterm(7M) .
jconvu has to be pushed when you set UTF—8 terminal. It converts up stream for UTF—8 into Japanese EUC and passes high module. It also converts down stream for Japanese EUC into UTF—8 and passes low module.
jconvu processes the following ioctls:
Start performing code conversion between UTF—8 and Japanese EUC for I/O stream.
Stop performing code conversion between UTF—8 and Japanese EUC for I/O stream.
See attributes(5) for descriptions of the following attributes:
|
setterm(1), stty(1), streamio(7I), jconv7 (7M), jconv8 (7M), jconvrs (7M), jconvru (7M), jconvs (7M), ldterm (7M), ptem (7M)
When you use jconvu with jconvrs (7M) or jconvru (7M) at a time and `raw' is specified by stty(1), code convert function automatically become off without specification by EUC_OXLON / EUC_OXLOFF .