Go to main content

man pages section 9: DDI and DKI Properties and Data Structures

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

aio_req(9S)

Name

aio_req - asynchronous I/O request structure

Synopsis

#include <sys/uio.h> 
#include <sys/aio_req.h> 
#include <sys/ddi.h> 
#include <sys/sunddi.h> 

Interface Level

Solaris DDI specific (Solaris DDI)

Description

An aio_req structure describes an asynchronous I/O request.

Structure Members

struct uio*aio_uio;   /* uio structure describing the I/O request */

The aio_uio member is a pointer to a uio(9S) structure, describing the I/O transfer request.

See Also

aphysio(9F), aread(9E), awrite(9E), uio(9S)