Go to main content

man pages section 9: DDI and DKI Properties and Data Structures

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

kstat(9S)

Name

kstat - kernel statistics structure

Synopsis

#include <sys/types.h>
#include <sys/kstat.h>
#include <sys/ddi.h>
#include <sys/sunddi.h>

Interface Level

Solaris DDI specific (Solaris DDI)

Description

Each kernel statistic (kstat) exported by device drivers consists of a header section and a data section. The kstat structure is the header portion of the statistic.

A driver receives a pointer to a kstat structure from a successful call to kstat_create(9F). Drivers should never allocate a kstat structure in any other manner.

After allocation, the driver should perform any further initialization needed before calling the kstat_install() function to actually export the kstat. For more information, see the kstat_install(9F) man page.

Structure Members


void      *ks_data;             /* kstat type-specif. data */
ulong_t   ks_ndata;             /* # of type-specif. data 
                                     records */
ulong_t   ks_data_size;         /* total size of kstat data 
                                   section */
int       (*ks_update)(struct kstat *, int);
void      *ks_private;          /* arbitrary provider-private 
                                   data */
void      *ks_lock;             /* protects kstat's data */

The members of the kstat structure available to examine or set by a driver are as follows:

ks_data

Points to the data portion of the kstat. Either allocated by the kstat_create() function for the drivers use, or by the driver if it is using virtual kstats. For more information, see the kstat_create(9F) man page.

ks_ndata

The number of data records in this kstat. Set by the ks_update(9E) routine.

ks_data_size

The amount of data pointed to by ks_data. Set by the ks_update(9E) routine.

ks_update

Pointer to a routine that dynamically updates kstat. This is useful for drivers where the underlying device keeps cheap hardware statistics, but where extraction is expensive. Instead of constantly keeping the kstat data section up to date, the driver can supply a ks_update() function that updates the kstat data section on demand. For more information, see the ks_update(9E) man page. To take advantage of this feature, set the ks_update field before calling the kstat_install() function. For more information, see the kstat_install(9F) man page.

ks_private

Is a private field for the driver's use. Often used in the ks_update() function. For more information, see the ks_update(9E) man page.

ks_lock

Is a pointer to a mutex that protects this kstat. kstat data sections are optionally protected by the per-kstat ks_lock. If ks_lock is non-NULL, kstat clients (such as /dev/kstat) will acquire this lock for all of their operations on that kstat. It is up to the kstat provider to decide whether guaranteeing consistent data to kstat clients is sufficiently important to justify the locking cost. Note, however, that most statistic updates already occur under one of the provider's mutexes. If the provider sets ks_lock to point to that mutex, then kstat data locking is free. ks_lock is really of type (kmutex_t*) and is declared as (void*) in the kstat header. That way, users do not have to be exposed to all of the kernel's lock-related data structures.

See Also

kstat_create(9F), kstat2(9S), kstat2_create(9F)

Writing Device Drivers in Oracle Solaris 11.4

Notes

With the introduction of kstats v2, direct use of these fields is deprecated. They may be renamed or removed in a future release of Oracle Solaris. For more information on how to access fields in a v2 kstat created by the kstat2_create() function, see the kstat2_create(9F) and kstat2(9S) man pages.