mac_ring_info - ring information data structure
Solaris architecture specific (Solaris DDI)
The mac_ring_info structure is used by a network device driver to describe it's RX and TX rings. The structure is used as an argument to the mr_rget(9E) driver entry point when querying the ring.
mac_ring_driver_t mri_driver; mac_ring_start_t mri_start; mac_ring_stop_t mri_stop; mac_intr_enable_t mri_intr_enable; mac_intr_disable_t mri_intr_disable; ddi_intr_handle_t mri_intr_ddi_handle; mac_ring_send_t mri_tx; mac_ring_poll_t mri_poll; mac_ring_stat_t mri_stat; uint_t mri_flags;
Filled by the driver as handle to the driver's ring structure.
The driver entry point for starting a driver's ring.
The driver entry point for stopping a driver ring.
The driver entry point for getting statistics for ring.
The driver entry point for transmitting packet for TX rings.
The driver entry point for polling RX ring for packets.
A set of flags for describing ring behavior.
The DDI interrupt handle associated with the interrupt for this ring.
For RX rings, this driver entry point will enable interrupts again and transition the driver polling to interrupt mode.
For RX rings, this driver entry point will disable interrupts and place the driver into polling mode.
See attributes(7) for descriptions of the following attributes: