mac_capab_lso, lso_basic_tcp_ipv4 - LSO capability data structure
Solaris architecture specific (Solaris DDI)
The mac_capab_lso and lso_basic_tcp_ipv4 structures are used by a device driver to describe its LSO capability. The structure is used as the argument to the mc_getcapab(9E) driver entry point when querying the MAC_CAPAB_LSO capability.
The mac_capab_lso data structure has the following members:
t_uscalar_t lso_flags; lso_basic_tcp_ipv4_t lso_basic_tcp_ipv4;
The fields must be set as follows:
Flag indicating the LSO capability supported by the device driver instance. The following flags are currently supported:
LSO for TCP on IPv4
Parameters for TCP LSO over IPv4
The lso_basic_tcp_ipv4 data structure is used by the device driver to advertise specific parameters when the LSO_TX_BASIC_TCP_IPV4 lso_flag is set. This data structure has the following elements:
The lso_max field contains the maximum payload size supported by the driver instance.
See attributes(7) for descriptions of the following attributes: