Go to main content

man pages section 9: DDI and DKI Properties and Data Structures

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

modlstrmod(9S)

Name

modlstrmod - linkage structure for loadable STREAMS modules

Synopsis

#include <sys/modctl.h> 

Interface Level

Solaris DDI specific (Solaris DDI)

Description

The modlstrmod structure is used by STREAMS modules to export module specific information to the kernel.

Structure Members

struct mod_ops     *strmod_modops;     
char               *strmod_linkinfo;  
struct fmodsw      *strmod_fmodsw;
strmod_modops

Must always be initialized to the address of mod_strmodops. This identifies the module as a loadable STREAMS module.

strmod_linkinfo

Can be any string up to MODMAXNAMELEN, and is used to describe the module. This string is usually the name of the module, but can contain other information (such as a version number).

strmod_fmodsw

Is a pointer to a template of a class entry within the module that is copied to the kernel's class table when the module is loaded.

See Also

modload(8)

Writing Device Drivers in Oracle Solaris 11.4