Go to main content

man pages section 9: DDI and DKI Properties and Data Structures

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

modldrv(9S)

Name

modldrv - linkage structure for loadable drivers

Synopsis

#include <sys/modctl.h> 

Interface Level

Solaris DDI specific (Solaris DDI)

Description

The modldrv structure is used by device drivers to export driver specific information to the kernel.

Structure Members


struct mod_ops    *drv_modops;     
char              *drv_linkinfo; 
struct dev_ops    *drv_dev_ops;
drv_modops

Must always be initialized to the address of mod_driverops. This member identifies the module as a loadable driver.

drv_linkinfo

Can be any string up to MODMAXNAMELEN characters (including the terminating NULL character), and is used to describe the module and its version number. This is usually the name of the driver and module version information, but can contain other information as well.

drv_dev_ops

Pointer to the driver's dev_ops(9S) structure.

See Also

add_drv(8), dev_ops(9S), modlinkage(9S)

Writing Device Drivers in Oracle Solaris 11.4