|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- restores system files to their content before ASET is installed
aset.restore [-d aset_dir]
aset.restore restores system files that are affected by the Automated Security Enhancement Tool (ASET) to their pre-ASET content. When ASET is executed for the first time, it saves and archives the original system files in the /usr/aset/archives directory. The aset.restore utility reinstates these files. It also deschedules ASET, if it is currently scheduled for periodic execution. See asetenv(4).
If you have made changes to system files after running ASET, these changes are lost when you run aset.restore. If you want to be absolutely sure that you keep the existing system state, it is recommended that you back-up your system before using aset.restore.
You should use aset.restore, under the following circumstances:
You want to remove ASET permanently and restore the original system (if you want to deactivate ASET, you can remove it from scheduling).
You are unfamiliar with ASET and want to experiment with it. You can use aset.restore to restore the original system state.
When some major system functionality is not working properly and you suspect that ASET is causing the problem; you may want to restore the system to see if the problem persists without ASET.
aset.restore requires root privileges to execute.
The following options are supported:
Specify the working directory for ASET. By default, this directory is /usr/aset. With this option the archives directory will be located under aset_dir.
archive of system files prior to executing aset
See attributes(5) for descriptions of the following attributes: