|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- install bootblocks in a disk partition
installboot [-F zfs|ufs|hsfs] bootblk raw-disk-device
The boot(1M) program, ufsboot, is loaded from disk by the bootblock program which resides in the boot area of a disk partition. This program is filesystem-specific, and must match the type of filesystem on the disk to be booted.
The boot objects are platform-dependent and reside in the /usr/platform/platform-name/lib/fs/file-system directory. The platform name can be found using the -i option of uname(1). The filesystem type can be found using:
% fstyp raw-disk-device
The installboot utility is a SPARC only program. It is not supported on the x86 architecture. x86 users should use installgrub(1M) instead.
The following option is supported:
Specifies the file system type of the boot block to be installed. Required if you wish to specify zfs or hsfs. The default is ufs.
The name of the bootblock code.
The name of the disk device onto which the bootblock code is to be installed; it must be a character device which is readable and writable. Naming conventions for a SCSI or IPI drive are c?t?d?s? and c?d?s? for an IDE drive.
Example 1 Installing UFS Boot Block
To install a ufs boot block on slice 0 of target 0 on controller 1 of the platform where the command is being run, use:
# installboot /usr/platform/`uname -i`/lib/fs/ufs/bootblk \ /dev/rdsk/c1t0d0s0
Example 2 Installing ZFS Boot Block
To install a ZFS boot block on slice 0 of target 0 on controller 1 of the platform where the command is being run, use syntax such as the following:
# installboot -F zfs /usr/platform/`uname -i`/lib/fs/zfs/bootblk \ /dev/rdsk/c0t1d0s0
Directory where boot objects reside.
See attributes(5) for descriptions of the following attributes:
The installboot utility fails if the bootblk or openfirmware files do not exist or if the raw disk device is not a character device.