|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- Solaris Web Start installer utility
installer [-locales list] [-nodisplay] [-noconsole] [-debug]
The installer utility invokes a Web Start install wizard sequence which will lead the user through a sequence of installation panels. This installer utility is found on many CDs that are shipped with Solaris and it will be found among the top level files of these CDs.
When the installer is on a CD being accessed from a desktop file manager, the installer can be double clicked to start the installation sequence. If the user is not currently the system's root user, the root user password will be requested.
The installer utility can also be run from other UNIX scripts. Usually, a script is used in conjunction with the utility's -nodisplay option. Add the -noconsole option for non-interactive scripts.
The following options are supported:
Selects product translations for install, corresponding to the specified list of locales if the specified locale translations are present on the installation media. Locales are supplied in a comma-separated list following the -locales option. An example list would appear as follows:
installer -locales fr,de,it
This would install products with translations for the French, German, and Italian locales.
Runs the install without a graphical user interface. Use the default product install unless it was modified by the -locales options.
Run the install without any interactive text console device. Useful when paired with -nodisplay for non-interactive UNIX script use.
Outputs extra information about what the install is doing. Mainly for install diagnostic purposes.
location of installation log files