|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- prepare an iPlanet Directory Server (iDS) to be populated with data and serve LDAP clients
/usr/lib/ldap/idsconfig [-v] [-i input_configfile] [-o output_configfile]
Use the idsconfig tool to set up an iPlanet Directory Server (iDS). You can specify the input configuration file with the -i option on the command line. Alternatively, the tool will prompt the user for configuration information. The input configuration file is created by idsconfig with the -o option on a previous run.
The first time a server is set up, the user is prompted for all the required information. Future installations on that machine can use the configuration file previously generated by idsconfig using the -o option.
The output configuration file contains the directory administrator's password in clear text. Thus, if you are creating an output configuration file, take appropriate security precautions.
You should back up the directory server's configuration and data prior to running this command.
The following options are supported:
Specify the file name for idsconfig to use as a configuration file. This file will be read by idsconfig, and the values in the file will be used to configure the server. Do not manually edit input_configfile. The input_configfile is only partially validated, as idsconfig assumes that the file was created by a previous invocation of the command.
Create a configuration file.
The following operands are supported:
Name of configuration file for idsconfig to use.
Configuration file created by idsconfig.
Example 1 Prompting the User for Input
In the following example, the user is prompted for information to set up iDS.
Example 2 Creating an Output Configuration File
In the following example, the user is prompted for information to set up iDS, and an output configuration file, config.1, is created when completed.
example# idsconfig -o config.1
Example 3 Setting up iDS Using the Specified Configuration File
In the following example, iDS is set up by using the values specified in the configuration file, config.1. The verbose mode is specified, so detailed information will print to the screen.
example# idsconfig -v -i config.1
The following exit values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes: