|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- configures the bd (buttons and dials) stream
bdconfig [startup] [off] [on] [term] [status] [verbose]
The bdconfig utility is responsible for configuring the autopush facility and defining to the system what serial device to use for the bd stream.
If no options are given, then an interactive mode is assumed. In this mode the current status is presented along with this usage line, and a series of interactive questions asked to determine the user's desires.
Root privilege is required to change the configuration. The status option does not require root privilege. bdconfig can be installed as a setuid root program.
The non-interactive options below can be given in any order.
Specify to the system the serial device for bd use. This option implies the on option unless the off option is present.
Reconfigure the configured term for tty use.
Reconfigure the configured term for bd use. If term has not been previously specified, interactive questions are asked to determine the user's desires.
Configure as was last configured before the system went down. This option is used by the startup script, and precludes the use of the on, off, and term options. This option implies non-interactive mode.
Emit the current configuration in terms of the words used as options: off, on, /dev/term/a, /dev/term/b, and so forth. This option implies non interactive mode.
bdconfig describes what it finds and what it is doing.
The bdconfig utility returns 0 on success, 1 on general error, and 2 on argument error.
See attributes(5) for descriptions of the following attributes:
All bdconfig does is configure the AUTOPUSH facility. bdconfig does not actually manipulate the serial port or stream in any way. Only the first open of a dismantled stream will see the effects of a previously run bdconfig.
The bdconfig utility is silent except for error messages unless:
invoked with no args: status / usage line emitted
interactive modes are invoked as described above
the verbose option is used
The interface does not support more than one dialbox and one buttonbox, both of which must be on the same serial device.
There should be a library routine to read, parse, and validate records in the iu.ap file, so that bdconfig could return to the appropriate record in iu.ap as the default configuration.