|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- configure data-link interfaces
dladm show-link [-s [-i interval]] [-p] [name]
dladm show-dev [-s [-i interval]] [-p] [dev]
dladm create-aggr [-t] [-R root-dir] [-P policy] [-l mode] [-T time] [-u address] -d dev [-d dev] ... key
dladm delete-aggr [-t] [-R root-dir] key
dladm add-aggr [-t] [-R root-dir] -d dev [-d dev] ... key
dladm remove-aggr [-t] [-R root-dir] -d dev [-d dev] ... key
dladm modify-aggr [-t] [-R root-dir] [-P policy] [-l mode] [-T time] [-u address] key
dladm show-aggr [-L] [-s [-i interval]] [-p] [key]
dladm set-linkprop [-t] [-R root-dir] -p prop=value[,...] name
dladm reset-linkprop [-t] [-R root-dir] [-p prop,...] name
dladm show-linkprop [-cP] [-p prop,...] [name]
The dladm command is used to configure data-links. A configured data-link is represented in the system as a STREAMS DLPI (v2) interface which may be plumbed under protocol stacks such as TCP/IP. Each data-link relies on either a single network device or an aggregation of devices to send packets to or receive packets from a network.
The dladm command operates on the following kinds of object:
Data-links, identified by a name. A name is a maximum of 30 characters. The first character must be alphabetic, the last numeric.
Aggregations of network devices, identified by a key.
Network devices, identified by concatenation of a driver name and an instance number.
The behavior of the linkprop subcommands depends on the type of link and underlying device, currently only one linkprop, “zone” is supported.
Some devices do not support configurable data-links or aggregations. The fixed data-links provided by such devices can be viewed using dladm, but can not be configured.
The following subcommands are supported:
Show configuration information for all data-links or the specified data-link. By default, the system is configured to have one data-link for each known network device.
Shows information for all devices or the specified device.
Creates an aggregation using the given key value from as many dev objects as are specified. A data-link is created by default, and is given a name which is the concatenation of “aggr” and the key value of the aggregation.
Deletes the specified aggregation.
Adds as many dev objects as are specified to the given aggregation.
Removes as many dev objects as are specified from the given aggregation.
Modifies the parameters of the given aggregation.
Shows configuration information for all aggregations or the specified aggregation.
Sets the values of one or more properties on the link specified by name. The list of properties and their possible values depend on the link type, the network device driver, and networking hardware, but can be retrieved using show-linkprop.
Resets one or more properties to their values on the link specified by name. If no properties are specified, all properties are reset.
Show the current values of one or more properties, either for all data-links or for the specified link name. If no properties are specified, all available link properties are displayed.
The following options are supported:
The key of an aggregation. This must be an integer value between 1 and 999.
A device specifier. This must be a concatenation of the name and instance of the driver bound to the device.
Specifies the port selection policy to use for load spreading of outbound traffic. The policy specifies which dev object is used to send packets. A policy consists of a list of one or more layers specifiers separated by commas. A layer specifier is one of the following:
Select outbound device according to source and destination MAC addresses of the packet.
Select outbound device according to source and destination IP addresses of the packet.
Select outbound device according to the upper layer protocol information contained in the packet. For TCP and UDP, this includes source and destination ports. For IPsec, this includes the SPI (Security Parameters Index.)
In the absence of a policy specification, dladm uses the default, L4.
As an example of use of the Lnum identifiers, to use upper layer protocol information, specify the following policy:
Note that, as the default, specification of L4 is superfluous.
To use the source and destination MAC addresses as well as the source and destination IP addresses, the following policy can be used:
Specifies whether LACP should be used and, if used, the mode in which it should operate. Legal values are off, active or passive.
Specifies the LACP timer value. The legal values are short or long.
Specifies a fixed unicast address to be used for the aggregation. If this option is not specified then an address is automatically chosen from the set of addresses of the component devices.
Specifies whether detailed LACP information should be displayed.
Used with the show-link, show-aggr, or show-dev subcommands to show the statistics of data-links, aggregations or devices, respectively.
Used with the -s option to specify an interval, in seconds, at which statistics should be displayed. If this option is not specified, statistics will only be displayed once.
Specifies that the change is temporary. Temporary changes last until the next reboot.
Specifies an alternate root directory where dladm applies changes. This can be useful in JumpStart scripts, where the root directory of the system being modified is mounted elsewhere.
Specifies that configuration information should be displayed in parseable format.
Displays help information. (Stops interpretation of subsequent arguments).
The following link properties listed below are supported. Note that these properties can be modified only temporarily through dladm, and thus the -t option must be specified. See the NOTES section for instructions on how to make property values persistent.
Specifies the zone to which the link belongs. Possible values consist of any exclusive-IP zone currently running on the system. By default, the zone binding is as per zonecfg(1M).
This link property controls the conditions in which 802.1Q VLAN tags will be inserted in packets being transmitted on the link. Two mode values can be assigned to this property:
Insert a VLAN tag in outgoing packets under the following conditions:
The packet belongs to a VLAN.
The user requested priority tagging.
Insert a VLAN tag only when the outgoing packet belongs to a VLAN. If a tag is being inserted in this mode and the user has also requested a non-zero priority, the priority is honored and included in the VLAN tag.
The default value is vlanonly.
Example 1 Configuring an Aggregation
To configure a data-link over an aggregation of devices bge0 and bge1 with key 1, enter the following command:
# dladm create-aggr -d bge0 -d bge1 1
See attributes(5) for descriptions of the following attributes:
There are two ways to make values for link properties persistent across reboots:
Using rc scripts.
Writing a transient smf(5) service.
The second method, using smf(5), is preferred.
To use the rc feature, perform steps such as the following:
Create a shell script, with permissions 744.
Store the script in /etc/rc3.d.
Inside the script, enter a command such as the following:
/usr/sbin/dladm set-linkprop -t -p tagmode=vlanonly ce1
In this example, it is the value for the tagmode property that is being made persistent. The interface ce1 is also particular to this example. Your interface name might be different.
See /etc/rc3.d /README for further guidance.
The second, preferred means of making values persistent is to use the smf(5) facility. To do so, perform steps such as the following:
Compose a manifest file. The following is an example of such a file:
<service_bundle type='manifest'name='apply_linkprop'> <service name='network/apply_linkprop' type='service' version='1'> <instance name='default' enabled='true'> <dependency name='dlmgmtd' grouping='require_all' restart_ov='none' type='service'> <service_fmri value='svc:/network/datalink-management:default' /> </dependency> <exec_method type='method' name='stop' exec=':true' timeout_seconds='3' /> <property_group name='startd' type='framework'> <propval name='duration' type='astring' value='transient' /> </property_group> </instance> <stability value='Evolving' /> </service> </service_bundle>
Store this file in /lib/svc/manifest/network/.
Create a shell script in /lib/svc/method that contains:
/usr/sbin/dladm set-linkprop -t tagmode=vlanonly ce1
The property, tagmode, and interface name, ce1, are examples. Use the names appropriate for your system.
Any additional properties you want to make persistent should be added, as separate commands, to the preceding shell script. There is no need to create an additional manifest file.