|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- check integrity of data cached with CacheFS
fsck -F cachefs [-m] [-o noclean] cache_directory
The CacheFS version of the fsck command checks the integrity of a cache directory.This utility corrects any CacheFS problems it finds by default. There is no interactive mode. The most likely invocation of fsck for CacheFS file systems is at boot time from an entry in the /etc/vfstab file. See vfstab(4).
The following options are supported:
Check, but do not repair.
Force a check on the cache even if there is no reason to suspect there is a problem.
Example 1 Using fsck_cachefs to Force a Check on the Cache Directory
The following example forces a check on the cache directory /cache3:
example% fsck -F cachefs -o noclean /cache3
See attributes(5) for descriptions of the following attributes: