|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- generate MOF file(s) from input SNMP MIB file(s)
/usr/sadm/bin/mib2mof [-n] [-d directory] [-q] [-c] [-a] [-h] files
The mib2mof utility reads input Management Information Base (MIB) files and produces one or more Managed Object Format (MOF) files. MOF files contain a Common Information Model (CIM) class declaration that represents the MIB for the Solaris Simple Network Management Protocol (SNMP) provider. The SNMP provider allows Web-Based Enterprise Management (WBEM) applications to access SNMP device information.
SNMP scalar variables map to properties in the CIM class. Qualifiers on each property convey the following MIB information for each scalar variable:
OID (Object IDentifier)
index (if the variable is within a group [sequence] that defines a row)
The syntax of an SNMP scalar variable is represented in a CIM class by the property's CIM datatype. All properties are marked with write access (true or false).
The following table shows how a Solaris SNMP datatype in a MIB maps to a Web-Based Enterprise Management (WBEM) CIM datatype and then to an SNMP datatype used by the WBEM SNMP API:
SNMP SMI Datatype SNMP CIM SNMP API Object type Ver. Datatype INTEGER v1 sint32 SnmpInt OCTET STRING v1 string SnmpString OBJECT IDENTIFIER v1 string SnmpOid IpAddress v1 string SnmpIpAddress Counter v1 uint32 SnmpCounter Gauge v1 uint32 SnmpGauge TimeTicks v1 uint32 SnmpTimeticks Opaque v1 sint8 SnmpOpaque DisplayString - see OCTET STRING v1 NetworkAddress - see IpAddress v1 Counter32 - see Counter v2 Counter64 v2 uint64 SnmpCounter64 Integer32 v2 sint32 SnmpInt Gauge32 - see Gauge v2 Unsigned32 v2 uint32 SnmpGauge TruthValue v2 sint32 SnmpInt BITS - see OCTET STRING v2
The mib2mof utility includes its required Solaris_SNMPmib_core.txt file (containing core MIB definitions), installed in /usr/sadm/mof. The mib2mof utility looks first for mib core file in local directory. If this file is not found in the local directory, mib2mof looks in /usr/sadm/mof.
A MOF file is generated for each SNMP group and table row sequence (that is, the columns in one row) found in the supplied MIBs. (This does not include the core MIB definitions contained in the Solaris_SNMPmib_core.txt file.)
There is no MOF file or property for an SNMP table - all table access is through the rows and columns of the table, and the SNMP variable for the table is marked as inaccessible in the MIB.
The MOF file created contains a CIM class that represents an SNMP group or row and a CIM class to represent a CIM association. The output file name (and CIM class) is of the format <SNMP_><MIB name><Group name>.mof.
The following options are supported:
Generate MOF files for all of the input MIB files. If -a is not given, a MOF file is generated only for the last file of the input list.
Do not use the default Solaris_SNMPmib_core.txt definitions file shipped with the Solaris SNMP Provider for WBEM. If this option is specified, you must specify another MIB_CORE definitions file as one of the input files.
Generate output MOF files in the specified directory.
Show how to invoke mib2mof and list its arguments.
Parse the input MIB files without generating any output.
Include the DESCRIPTION clause of SNMP OBJECT-TYPE as a qualifier in the generated MOF file.
The following operands are supported:
List of SNMP MIB files to be converted.
The mib2mof utility terminates with exit status 0.
See attributes(5) for descriptions of the following attributes: