|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- notify timezone update
The tzreload command notifies active (running) processes to reread timezone information. The timezone information is cached in each process, absent a tzreload command, is never reread until a process is restarted. In response to a tzreload command, active processes reread the current timezone information at the next call to ctime(3C) and mktime(3C). The tzreload notification is sent to processes within the current zone.
tzreload causes processes which are using the system timezone (in /etc/default/init) to reread the contents of that file.
In addition to notifying active processes, the tzreload command also notifies cron(1M), to reinitialize the job scheduler with the new timezone information.
Standard zone information directory.
See attributes(5) for descriptions of the following attributes:
Although tzreload reinitializes cron(1M), applications that are affected by timezone changes still need to be restarted or reinitialized if they do not reread the new timezone information before timezone changes take place.
The timezone update service is managed by the service management facility, smf(5), under the service identifier:
Refreshing this service causes the tzreload command to be run, notifying running processes to reload their timezone caches. Disabling this service is not recommended.