|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- construct a FAT file system
mkfs -F pcfs [generic_options] [-o FSType_specific_options] raw_device_file
The pcfs-specific module of mkfs constructs a File Allocation Table (FAT) on removable media (JAZ disk, ZIP disk, PCMCIA card), a hard disk, or a file (see NOTES). FATs are the standard MS-DOS and Windows file system format.
mkfs for pcfs determines an appropriate FAT size for the medium, then it installs an initial boot sector and an empty FAT. A sector size of 512 bytes is used. mkfs for pcfs can also install the initial file in the file system (see the pcfs-specific -o i option). This first file can optionally be marked as read-only, system, and/or hidden.
If you want to construct a FAT with mkfs for pcfs on a medium that is not formatted, you must first perform a low-level format on the medium with format(1M). The media must also be partitioned with the fdisk(1M) utility. Note that all existing data on a disk partition, if any, is destroyed when a new FAT is constructed.
generic_options are supported by the generic mkfs command. See mkfs(1M) for a description of these options.
raw_device_file indicates the device on which to write unless the -o N option has been specified, or if the -V or -m generic options are passed from the generic mkfs module.
See mkfs(1M) for the list of supported generic options.
The following options are supported:
Specify pcfs file system-specific options in a comma-separated list with no intervening spaces. If invalid options are specified, a warning message is printed and the invalid options are ignored.
Label the media with volume label. The volume label is restricted to 11 uppercase characters.
Install filename as the boot loader in the file system's boot sector. If you don't specify a boot loader, an MS-DOS boot loader is installed. The MS-DOS boot loader requires specific MS-DOS system files to make a disk bootable. See NOTES for more information.
The size of a FAT entry. Currently, 12, 16, and 32 are valid values. The default is 16.
Mark the first file installed as a hidden file. The -i option must also be specified.
Set the number of hidden sectors to n. This is the number of sectors on the physical disk preceding the start of the volume (which is the boot sector itself). This defaults to a computed valued (based on the fdisk table) for disks. This option may be used only in conjunction with the nofdisk option.
Install filename as the initial file in the new file system. The initial file's contents are guaranteed to occupy consecutive clusters at the start of the files area. When creating bootable media, a boot program should be specified as the initial file.
Do not attempt to find an fdisk table on the medium. Instead rely on the size option for determining the partition size. By default, the created FAT is 16 bits and begins at the first sector of the device. This origination sector can be modified with the hidden option (-h).
The number of sectors per track on the disk. If not specified, the value is determined by using a dkio(7I) ioctl to get the disk geometry.
The number of tracks per cylinder on the disk. If not specified, the value is determined by using a dkio(7I) ioctl to get the disk geometry.
No execution mode. Print normal output, but do not actually write the file system to the medium. This is most useful when used in conjunction with the verbose option.
Mark the first file installed as read-only. The -i option must also be specified.
Set the number of reserved sectors to n. This is the number of sectors in the volume, preceding the start of the first FAT, including the boot sector. The value should always be at least 1, and the default value is exactly 1.
Mark the first file installed as a system file. The -i option must also be specified.
The number of sectors in the file system. If not specified, the value is determined from the size of the partition given in the fdisk table.
The size of the allocation unit for space within the file system, expressed as a number of sectors. The default value depends on the FAT entry size and the size of the file system.
Verbose output. Describe, in detail, operations being performed.
The device on which to build the FAT.
mkfs_pcfs supports MBR (Master Boot Record) partitions and GPT (GUID Partition Table) partitions. GPT is part of the EFI (Extensible Firmware Interface) standard. For both x86 and SPARC, for a GPT-labeled disk, you can specify the partition using the logical device pathname with no suffix, for example, /dev/rdsk/c0t0d0s0. In GPT, this corresponds to the first partition on the disk.
On x86 for MBR partitions, you can specify the proper partition using the logical device pathname corresponding to the partition. For example, /dev/rdsk/c0t0d0p1 corresponds to first partition in the MBR, or /dev/rdsk/c0t0d0p5 corresponds to first logical partition in the extended partition. Alternatively, using a suffix is also acceptable. For example, in /dev/rdsk/c0t0d0p0:c, mkfs_pcfs recognizes :c as the first partition that can accept a FAT file system.
For removable media with MBR partitions on SPARC, you need to specify a disk device name with a suffix to indicate the proper partition. For example, in the name /dev/rdsk/c0t0d0s2:c, the :c suffix indicates that the partition can accept the new FAT.
For a file, raw_device_file is the block device name returned by lofiadm(1M).
The media in these examples must be formatted before running mkfs for pcfs. See DESCRIPTION for more details.
Example 1 Creating a FAT File System on a Disk
The following command creates a FAT file system on the second fdisk partition of a disk attached to an x86 based system:
mkfs -F pcfs /dev/rdsk/c0d0p0:d
Example 2 Creating a FAT File System on a ZIP Disk
The following command creates a FAT file system on a ZIP disk located on a SPARC based system:
mkfs -F pcfs /dev/rdsk/c0t4d0s2:c
Example 3 Creating a FAT File System on a JAZ Disk
The following command creates a FAT file system on a JAZ disk located on a SPARC based system and overrides the sectors/track and tracks/cylinder values obtained from the device's controller:
mkfs -F pcfs -o nsect=32,ntrack=64 /dev/rdsk/c0t3d0s2:c
See attributes(5) for descriptions of the following attributes:
You can use lofiadm to create a file that appears to a mkfs command (for example, mkfs_pcfs or mkfs_ufs) as a raw device. You can then use a mkfs command to create a file system on that device. See lofiadm(1M) for examples of creating a UFS and a PC (FAT) file system on a device created by lofiadm.