|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- maintain password-strength checking database
/usr/bin/mkpwdict [-s dict1,... ,dictN] [-d destination-path]
Files containing words to be added to the database can be specified on the command-line using the -s flag. These source files should have a single word per line, much like /usr/share/lib/dict/words.
If -s is omitted, mkpwdict will use the value of DICTIONLIST specified in /etc/default/passwd (see passwd(1)).
The database is created in the directory specified by the -d option. If this option is omitted, mkpwdict uses the value of DICTIONDBDIR specified in /etc/default/passwd (see passwd(1)). The default location is /var/passwd.
The following options are supported:
Specifies a comma-separated list of files containing words to be added to the dictionary-lookup database.
Specifies the target location of the dictionary-database.
default destination directory
See attributes(5) for descriptions of the following attributes: