|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- ufs file system quota consistency checker
quotacheck [-fp] [-v] filesystem...
quotacheck -a [-fpv]
quotacheck examines each mounted ufs file system, builds a table of current disk usage, and compares this table against the information stored in the file system's disk quota file. If any inconsistencies are detected, both the quota file and the current system copy of the incorrect quotas are updated.
filesystem is either a file system mount point or the block device on which the file system resides.
quotacheck expects each file system to be checked to have a quota file named quotas in the root directory. If none is present, quotacheck will not check the file system.
quotacheck accesses the character special device in calculating the actual disk usage for each user. Thus, the file systems that are checked should be quiescent while quotacheck is running.
The following options are supported:
Check the file systems which /etc/mnttab indicates are ufs file systems. These file systems must be read-write mounted with disk quotas enabled, and have an rq entry in the mntopts field in /etc/vfstab.
Force check on file systems with logging enabled. Use in combination with the -p option.
Check quotas of file systems in parallel. For file systems with logging enabled, no check is performed unless the -f option is also specified.
Indicate the calculated disk quotas for each user on a particular file system. quotacheck normally reports only those quotas modified.
See largefile(5) for the description of the behavior of quotacheck when encountering files greater than or equal to 2 Gbyte ( 231 bytes).
Mounted file systems
List of default parameters for each file system
See attributes(5) for descriptions of the following attributes: