|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- administrative control
/usr/sbin/uadmin cmd fcn [mdep]
The uadmin command provides control for basic administrative functions. This command is tightly coupled to the system administration procedures and is not intended for general use. It may be invoked only by the super-user.
Both the cmd (command) and fcn (function) arguments are converted to integers and passed to the uadmin system call. The optional mdep (machine dependent) argument is only available for the cmd values of 1 (A_REBOOT), 2 (A_SHUTDOWN), or 5 (A_DUMP). For any other cmd value, no mdep command-line argument is allowed.
When passing an mdep value that contains whitespaces, the string must be grouped together as a single argument enclosed within quotes, for example:
uadmin 1 1 “-s kernel/unix”
See attributes(5) for descriptions of the following attributes:
Shutting down or halting the system by means of uadmin does not update the boot archive. Avoid using this command after
editing of files such as /etc/system
installing new driver binaries or kernel binaries
updating existing driver binaries or kernel binaries.