|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- network configuration management daemon
netcfgd is a system daemon to manage network configuration. This daemon is started automatically by svc:/network/netcfg:default and should not be invoked directly. It does not constitute a programming interface.
netcfgd manages access to a network configuration repository, insuring that readers and writers have the appropriate authorizations. The required authorizations vary, depending on the portion of the database being accessed.
The solaris.network.interface.config authorization and the sys_dl_config privilege are obtained by means of the Network Management security profile. The solaris.network.autoconf.read authorization is part of the Basic Solaris User profile. The solaris.network.autoconf.wlan and .select authorizations are obtained by means of the Network Autoconf User profile, and the autoconf.write authorization, plus those included in the Network Autoconf User profile, are obtained by means of the Network Autoconf Admin profile.
See attributes(5) for descriptions of the following attributes:
See also nwam-manager(1M), available in the JDS/GNOME man page collection.