|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- delete a role's login from the system
roledel [-r] [-S repository] role
The roledel utility deletes a role account from the system and makes the appropriate account-related changes to the system file and file system. roledel also removes the role from each user's list of assumable roles.
An administrator must be granted the User Management Profile to be able to delete an existing role.
The following options are supported:
Remove the role's home directory from the system. This directory must exist. The files and directories under the home directory will no longer be accessible following successful execution of the command. The ZFS dataset that was created for the role's home directory will be removed.
The auto_home entry for the role will be deleted.
The valid repositories are files, ldap. The repository specifies which name service will be updated. The default repository is files.
The following operands are supported:
An existing role name to be deleted.
The following exit values are returned:
Invalid command syntax. A usage message for the roledel command is displayed.
The account to be removed does not exist.
The account to be removed is in use.
Cannot update the /etc/group or /etc/user_attr file but the login is removed from the /etc/passwd file.
Cannot remove or otherwise modify the home directory.
system password file
system file containing roles' encrypted passwords and related information
system file containing group definitions
system file containing additional role attributes
See attributes(5) for descriptions of the following attributes:
auths(1), passwd(1), profiles(1), roles(1), users(1B), groupadd(1M), groupdel(1M), groupmod(1M), logins(1M), roleadd(1M), rolemod(1M), useradd(1M), userdel(1M), usermod(1M), passwd(4), prof_attr(4), user_attr(4), attributes(5)
The roledel utility only deletes an account definition that is in the group, passwd, shadow, and user_attr databases in the repository.